ietf-netconf-monitoring
NETCONF Monitoring Module.
All elements in this module are read-only.
This version of this YANG module is part of RFC 6022;
YANG Tree Diagram
module: ietf-netconf-monitoring
+--ro netconf-state
+--ro capabilities
| +--ro capability* inet:uri
+--ro datastores
| +--ro datastore* [name]
| +--ro name netconf-datastore-type
+--ro schemas
+--ro schema* [identifier version format]
+--ro identifier string
+--ro version string
+--ro format identityref
+--ro namespace inet:uri
+--ro location* union
rpcs:
+---x get-schema
+---w input
| +---w identifier string
| +---w version? string
| +---w format? identityref
+--ro output
+--ro data? <anydata>Resources
Resource List
Path | Access |
|---|---|
/netconf-state | Read-Only |
/netconf-state/capabilities | Read-Only |
/netconf-state/capabilities/capability | Read-Only |
/netconf-state/datastores | Read-Only |
/netconf-state/datastores/datastore | Read-Only |
/netconf-state/datastores/datastore/name | Read-Only |
/netconf-state/schemas | Read-Only |
/netconf-state/schemas/schema | Read-Only |
/netconf-state/schemas/schema/identifier | Read-Only |
/netconf-state/schemas/schema/version | Read-Only |
/netconf-state/schemas/schema/format | Read-Only |
/netconf-state/schemas/schema/namespace | Read-Only |
/netconf-state/schemas/schema/location | Read-Only |
Detailed Nodes
/netconf-state
Path
/netconf-state
Node Type
container
Description
The netconf-state container is the root of the monitoring data model.
Access
Read-Only
/netconf-state/capabilities
Path
/netconf-state/capabilities
Node Type
container
Description
Contains the list of NETCONF capabilities supported by the server.
Access
Read-Only
/netconf-state/capabilities/capability
Path
/netconf-state/capabilities/capability
Node Type
leaf-list
Description
List of NETCONF capabilities supported by the server.
Access
Read-Only
Data Type
<YANG type uri>
Constraints
The uri type represents a Uniform Resource Identifier (URI) as defined by the rule 'URI' in RFC 3986.
Objects using the uri type MUST be in US-ASCII encoding, and MUST be normalized as described by RFC 3986 Sections 6.2.1, 6.2.2.1, and 6.2.2.2. Characters that can be represented without using percent-encoding are represented as characters (without percent-encoding), and all case-insensitive characters are set to lowercase except for hexadecimal digits within a percent-encoded triplet, which are normalized to uppercase as described in
Section 6.2.2.1 of RFC 3986.
The purpose of this normalization is to help provide unique URIs. Note that this normalization is not sufficient to provide uniqueness. Two URIs that are textually distinct after this normalization may still be equivalent.
Objects using the uri type may restrict the schemes that they permit. For example, 'data:' and 'urn:' schemes might not be appropriate.
A zero-length URI is not a valid URI. This can be used to express 'URI absent' where required.
In the value set and its semantics, this type is equivalent to the Uri SMIv2 textual convention defined in RFC 5017.
/netconf-state/datastores
Path
/netconf-state/datastores
Node Type
container
Description
Contains the list of NETCONF configuration datastores.
Access
Read-Only
/netconf-state/datastores/datastore
Path
/netconf-state/datastores/datastore
Node Type
list
Description
List of NETCONF configuration datastores supported by the NETCONF server and related information.
Access
Read-Only
/netconf-state/datastores/datastore/name
Path
/netconf-state/datastores/datastore/name
Node Type
leaf
Description
Name of the datastore associated with this list entry.
Access
Read-Only
Data Type
<YANG type netconf-datastore-type>
Constraints
Enumeration with options:
- running
- startup
- operational
/netconf-state/schemas
Path
/netconf-state/schemas
Node Type
container
Description
Contains the list of data model schemas supported by the server.
Access
Read-Only
/netconf-state/schemas/schema
Path
/netconf-state/schemas/schema
Node Type
list
Description
List of data model schemas supported by the server.
Access
Read-Only
/netconf-state/schemas/schema/identifier
Path
/netconf-state/schemas/schema/identifier
Node Type
leaf
Description
Identifier to uniquely reference the schema. The identifier is used in the <get-schema> operation and may be used for other purposes such as file retrieval.
For modeling languages that support or require a data model name (e.g., YANG module name) the identifier MUST match that name. For YANG data models, the identifier is the name of the module or submodule. In other cases, an identifier such as a filename MAY be used instead.
Access
Read-Only
Data Type
<YANG type string>
/netconf-state/schemas/schema/version
Path
/netconf-state/schemas/schema/version
Node Type
leaf
Description
Version of the schema supported. Multiple versions MAY be supported simultaneously by a NETCONF server. Each version MUST be reported individually in the schema list, i.e., with same identifier, possibly different location, but different version.
For YANG data models, version is the value of the most recent YANG 'revision' statement in the module or submodule, or the empty string if no 'revision' statement is present.
Access
Read-Only
Data Type
<YANG type string>
/netconf-state/schemas/schema/format
Path
/netconf-state/schemas/schema/format
Node Type
leaf
Description
The data modeling language the schema is written in (currently xsd, yang, yin, rng, or rnc).
For YANG data models, 'yang' format MUST be supported and 'yin' format MAY also be provided.
Access
Read-Only
Data Type
<YANG type identityref>
Constraints
IdentityRef with options:
- yang
/netconf-state/schemas/schema/namespace
Path
/netconf-state/schemas/schema/namespace
Node Type
leaf
Description
The XML namespace defined by the data model.
For YANG data models, this is the module's namespace.
If the list entry describes a submodule, this field contains the namespace of the module to which the submodule belongs.
Access
Read-Only
Data Type
<YANG type uri>
Constraints
The uri type represents a Uniform Resource Identifier (URI) as defined by the rule 'URI' in RFC 3986.
Objects using the uri type MUST be in US-ASCII encoding, and MUST be normalized as described by RFC 3986 Sections 6.2.1, 6.2.2.1, and 6.2.2.2. Characters that can be represented without using percent-encoding are represented as characters (without percent-encoding), and all case-insensitive characters are set to lowercase except for hexadecimal digits within a percent-encoded triplet, which are normalized to uppercase as described in
Section 6.2.2.1 of RFC 3986.
The purpose of this normalization is to help provide unique URIs. Note that this normalization is not sufficient to provide uniqueness. Two URIs that are textually distinct after this normalization may still be equivalent.
Objects using the uri type may restrict the schemes that they permit. For example, 'data:' and 'urn:' schemes might not be appropriate.
A zero-length URI is not a valid URI. This can be used to express 'URI absent' where required.
In the value set and its semantics, this type is equivalent to the Uri SMIv2 textual convention defined in RFC 5017.
Mandatory
Yes
/netconf-state/schemas/schema/location
Path
/netconf-state/schemas/schema/location
Node Type
leaf-list
Description
One or more locations from which the schema can be retrieved. This list SHOULD contain at least one entry per schema.
A schema entry may be located on a remote file system (e.g., reference to file system for ftp retrieval) or retrieved directly from a server supporting the <get-schema> operation (denoted by the value 'NETCONF').
Access
Read-Only
Data Type
<YANG type union>
Constraints
Multiple constraints:
- Enumeration with options:
- NETCONF
- The uri type represents a Uniform Resource Identifier (URI) as defined by the rule 'URI' in RFC 3986.
Objects using the uri type MUST be in US-ASCII encoding, and MUST be normalized as described by RFC 3986 Sections 6.2.1, 6.2.2.1, and 6.2.2.2. Characters that can be represented without using percent-encoding are represented as characters (without percent-encoding), and all case-insensitive characters are set to lowercase except for hexadecimal digits within a percent-encoded triplet, which are normalized to uppercase as described in
Section 6.2.2.1 of RFC 3986.
The purpose of this normalization is to help provide unique URIs. Note that this normalization is not sufficient to provide uniqueness. Two URIs that are textually distinct after this normalization may still be equivalent.
Objects using the uri type may restrict the schemes that they permit. For example, 'data:' and 'urn:' schemes might not be appropriate.
A zero-length URI is not a valid URI. This can be used to express 'URI absent' where required.
In the value set and its semantics, this type is equivalent to the Uri SMIv2 textual convention defined in RFC 5017.